#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)\? # match the literal characters 'text'" & @CRLF & _
"(?= # start lookahead" & @CRLF & _
" [^"']* # match any number of non-quote characters" & @CRLF & _
" (?: # start non-capturing group, repeated zero or more times" & @CRLF & _
" ("|')[^\1]*\1 # one quoted portion of text" & @CRLF & _
" [^"']* # any number of non-quote characters" & @CRLF & _
" )* # end non-capturing group" & @CRLF & _
" $ # match end of the string" & @CRLF & _
") # end lookahead"
Local $sString = "test ? query" & @CRLF & _
"query ? test "text ? text" test ? id" & @CRLF & _
"query ? test 'text ? text' test ? eee" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM table1 WHERE id = ?" & @CRLF & _
"SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')" & @CRLF & _
"SELECT * FROM table1 WHERE (id IN (?)) AND (path = "test?text")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")