using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\? # match the literal characters 'text'
(?= # start lookahead
[^""']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
(""|')[^\1]*\1 # one quoted portion of text
[^""']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead";
string input = @"test ? query
query ? test ""text ? text"" test ? id
query ? test 'text ? text' test ? eee
SELECT * FROM table1 WHERE id = ?
SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')
SELECT * FROM table1 WHERE (id IN (?)) AND (path = ""test?text"")";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}