# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\? # match the literal characters 'text'
(?= # start lookahead
[^"']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
("|')[^\1]*\1 # one quoted portion of text
[^"']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead
"""
test_str = ("test ? query\n"
"query ? test \"text ? text\" test ? id\n"
"query ? test 'text ? text' test ? eee\n\n"
"SELECT * FROM table1 WHERE id = ?\n"
"SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')\n"
"SELECT * FROM table1 WHERE (id IN (?)) AND (path = \"test?text\")")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.