const regex = /\? # match the literal characters 'text'
(?= # start lookahead
[^"']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
("|')[^\1]*\1 # one quoted portion of text
[^"']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\? # match the literal characters \'text\'
(?= # start lookahead
[^"\']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
("|\')[^\\1]*\\1 # one quoted portion of text
[^"\']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead', 'gmi')
const str = `test ? query
query ? test "text ? text" test ? id
query ? test 'text ? text' test ? eee
SELECT * FROM table1 WHERE id = ?
SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')
SELECT * FROM table1 WHERE (id IN (?)) AND (path = "test?text")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}