$re = '/\? # match the literal characters \'text\'
(?= # start lookahead
[^"\']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
("|\')[^\1]*\1 # one quoted portion of text
[^"\']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead/mix';
$str = 'test ? query
query ? test "text ? text" test ? id
query ? test \'text ? text\' test ? eee
SELECT * FROM table1 WHERE id = ?
SELECT * FROM table1 WHERE (id IN (?)) AND (path = \'test?text\')
SELECT * FROM table1 WHERE (id IN (?)) AND (path = "test?text")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);