import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\? # match the literal characters 'text'\n"
+ "(?= # start lookahead\n"
+ " [^\"']* # match any number of non-quote characters\n"
+ " (?: # start non-capturing group, repeated zero or more times\n"
+ " (\"|')[^\\1]*\\1 # one quoted portion of text\n"
+ " [^\"']* # any number of non-quote characters\n"
+ " )* # end non-capturing group\n"
+ " $ # match end of the string\n"
+ ") # end lookahead";
final String string = "test ? query\n"
+ "query ? test \"text ? text\" test ? id\n"
+ "query ? test 'text ? text' test ? eee\n\n"
+ "SELECT * FROM table1 WHERE id = ?\n"
+ "SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')\n"
+ "SELECT * FROM table1 WHERE (id IN (?)) AND (path = \"test?text\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}