package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\? # match the literal characters 'text'
(?= # start lookahead
[^"']* # match any number of non-quote characters
(?: # start non-capturing group, repeated zero or more times
("|')[^\1]*\1 # one quoted portion of text
[^"']* # any number of non-quote characters
)* # end non-capturing group
$ # match end of the string
) # end lookahead`)
var str = `test ? query
query ? test "text ? text" test ? id
query ? test 'text ? text' test ? eee
SELECT * FROM table1 WHERE id = ?
SELECT * FROM table1 WHERE (id IN (?)) AND (path = 'test?text')
SELECT * FROM table1 WHERE (id IN (?)) AND (path = "test?text")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}