#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_"
Local $sString = " _dsfsdF_ _sdf\_sd\_f_ \_sdsdfsdfd\_ "
Local $sSubst = "$1$2<b>$3</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)