import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^\\\\])((?:\\\\{2})*)_([^_\\\\]*(?:\\\\.[^_\\\\]*)*)_";
final String string = " _dsfsdF_ _sdf\\_sd\\_f_ \\_sdsdfsdfd\\_ ";
final String subst = "$1$2<b>$3</b>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}