package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_`)
var str = ` _dsfsdF_ _sdf\_sd\_f_ \_sdsdfsdfd\_ `
var substitution = "$1$2<b>$3</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}