// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_").unwrap();
let string = " _dsfsdF_ _sdf\\_sd\\_f_ \\_sdsdfsdfd\\_ ";
let substitution = "$1$2<b>$3</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}