use strict;
my $str = ' _dsfsdF_ _sdf\\_sd\\_f_ \\_sdsdfsdfd\\_ ';
my $regex = qr/(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_/p;
my $subst = '$1$2<b>$3</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";