re = /(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_/
str = ' _dsfsdF_ _sdf\\_sd\\_f_ \\_sdsdfsdfd\\_ '
subst = '$1$2<b>$3</b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result