const regex = /(^|[^\\])((?:\\{2})*)_([^_\\]*(?:\\.[^_\\]*)*)_/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^\\\\])((?:\\\\{2})*)_([^_\\\\]*(?:\\\\.[^_\\\\]*)*)_', 'g')
const str = ` _dsfsdF_ _sdf\\_sd\\_f_ \\_sdsdfsdfd\\_ `;
const subst = `$1$2<b>$3</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);