#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$"
Local $sString = "facebook.com" & @CRLF & _
"facebook-test.com" & @CRLF & _
"bbc.co.uk" & @CRLF & _
"bbc-test.co.uk" & @CRLF & _
"192.168.0.1" & @CRLF & _
"0.1" & @CRLF & _
"ee-outage.s3.amazonaws.com" & @CRLF & _
"an-éxample-domain.com" & @CRLF & _
"" & @CRLF & _
"an-x%mple-domain.com" & @CRLF & _
"abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz" & @CRLF & _
"abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz" & @CRLF & _
"my'domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")