import re
regex = re.compile(r"^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("facebook.com\n"
"facebook-test.com\n"
"bbc.co.uk\n"
"bbc-test.co.uk\n"
"192.168.0.1\n"
"0.1\n"
"ee-outage.s3.amazonaws.com\n"
"an-éxample-domain.com\n\n"
"an-x%mple-domain.com\n"
"abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz\n"
"abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz\n"
"my'domain.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")