const regex = /^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\\.(?:[a-z])+?$', 'igm')
const str = `facebook.com
facebook-test.com
bbc.co.uk
bbc-test.co.uk
192.168.0.1
0.1
ee-outage.s3.amazonaws.com
an-éxample-domain.com
an-x%mple-domain.com
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz
my'domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}