import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\\.(?:[a-z])+?$";
final String string = "facebook.com\n"
+ "facebook-test.com\n"
+ "bbc.co.uk\n"
+ "bbc-test.co.uk\n"
+ "192.168.0.1\n"
+ "0.1\n"
+ "ee-outage.s3.amazonaws.com\n"
+ "an-éxample-domain.com\n\n"
+ "an-x%mple-domain.com\n"
+ "abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz\n"
+ "abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz\n"
+ "my'domain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}