# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$//gm;t' <<< "12344A.ffdsaaddd
12344aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq"