using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$";
string substitution = @"";
string input = @"12344A.ffdsaaddd
12344aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}