$re = '/^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$/m';
$str = '12344A.ffdsaaddd
12344aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;