use strict;
my $str = '12344A.ffdsaaddd
12344aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq';
my $regex = qr/^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";