import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-zA-Z])((?=.*\\d)|(?=.*\\W)).{10,20}$";
final String string = "12344A.ffdsaaddd\n"
+ "12344aaav\n"
+ "12344aaavq\n"
+ "fffffffffffasdfasdfas\n"
+ "A**.2344aaavq";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}