import re
regex = re.compile(r"^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$", flags=re.MULTILINE)
test_str = ("12344A.ffdsaaddd\n"
"12344aaav\n"
"12344aaavq\n"
"fffffffffffasdfasdfas\n"
"A**.2344aaavq")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)