re = /^(?=.*[a-zA-Z])((?=.*\d)|(?=.*\W)).{10,20}$/m
str = '12344A.ffdsaaddd
12344aaav
12344aaavq
fffffffffffasdfasdfas
A**.2344aaavq'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result