using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+%) (.*)|(.*?) (\d+%)$";
string input = @"abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn't get matched 5
12 this neither";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}