$re = '/^(\d+%) (.*)|(.*?) (\d+%)$/m';
$str = 'abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn\'t get matched 5
12 this neither';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);