// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+%) (.*)|(.*?) (\d+%)$").unwrap();
let string = "abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn't get matched 5
12 this neither";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}