import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+%) (.*)|(.*?) (\\d+%)$";
final String string = "abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%\n"
+ "12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž\n"
+ "some āē text 124%\n"
+ "123% some āē text\n"
+ "this shouldn't get matched 5\n"
+ "12 this neither";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}