re = /^(\d+%) (.*)|(.*?) (\d+%)$/m
str = 'abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn\'t get matched 5
12 this neither'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end