import Foundation
let pattern = #"^(\d+%) (.*)|(.*?) (\d+%)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn't get matched 5
12 this neither
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)