const regex = /^(\d+%) (.*)|(.*?) (\d+%)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+%) (.*)|(.*?) (\\d+%)$', 'gm')
const str = `abc3442341%adef#!@\$%^&*()[]-zāēūīšģķļņž 12%
12% abc3442341%adef#!@\$%^&*()[]-zāēūīšģķļņž
some āē text 124%
123% some āē text
this shouldn't get matched 5
12 this neither`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}