# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*image_crop_resized=(.*)&video_still_time(.*)/\1/;t' <<< "https://embed-ssl.wistia.com/deliveries/c0238be7cc8c8f0bd8ecb6edf3c6f8f1.jpg?image_crop_resized=250x250&video_still_time=33"