package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*image_crop_resized=(.*)&video_still_time(.*)`)
var str = []byte(`https://embed-ssl.wistia.com/deliveries/c0238be7cc8c8f0bd8ecb6edf3c6f8f1.jpg?image_crop_resized=250x250&video_still_time=33`)
var substitution = []byte("\1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}