#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[(\w*\.?)\]"
Local $sString = "[Amount]+[amount2]" & @CRLF & _
"[dto.Attributes]+[dto.Attributes]" & @CRLF & _
"[dto.Attributes.Amount]+[dto.Attributes.Amount]" & @CRLF & _
"[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]" & @CRLF & _
"[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")