// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[(\w*\.?)\]").unwrap();
let string = "[Amount]+[amount2]
[dto.Attributes]+[dto.Attributes]
[dto.Attributes.Amount]+[dto.Attributes.Amount]
[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]
[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}