re = /\[(\w*\.?)\]/i
str = '[Amount]+[amount2]
[dto.Attributes]+[dto.Attributes]
[dto.Attributes.Amount]+[dto.Attributes.Amount]
[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]
[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end