import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(\\w*\\.?)\\]";
final String string = "[Amount]+[amount2]\n"
+ "[dto.Attributes]+[dto.Attributes]\n"
+ "[dto.Attributes.Amount]+[dto.Attributes.Amount]\n"
+ "[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]\n"
+ "[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}