const regex = /\[(\w*\.?)\]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\w*\\.?)\\]', 'ig')
const str = `[Amount]+[amount2]
[dto.Attributes]+[dto.Attributes]
[dto.Attributes.Amount]+[dto.Attributes.Amount]
[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]
[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}