using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w*\.?)\]";
string input = @"[Amount]+[amount2]
[dto.Attributes]+[dto.Attributes]
[dto.Attributes.Amount]+[dto.Attributes.Amount]
[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]
[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}