$re = '/\[(\w*\.?)\]/i';
$str = '[Amount]+[amount2]
[dto.Attributes]+[dto.Attributes]
[dto.Attributes.Amount]+[dto.Attributes.Amount]
[dto.Attributes.SalesDeptGross.Amount]+[dto.Attributes.FinanceDeptGross.Amount]
[dto.Attributes.SalesDeptGross.Amount.test]+[dto.Attributes.FinanceDeptGross.Amount.test]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);