#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^{].*=([^=]*)=.*[^}]"
Local $sString = "Should not match:" & @CRLF & _
"" & @CRLF & _
"fyfffy d { dffd =heyyyy= g g dsg gs } d xgg g" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Should match:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"fyfffy d dffd =heyyyy= g g dsg gs d xgg g"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")