const regex = /[^\x00-\x7F]{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\x00-\\x7F]{2,}', 'gm')
const str = `
mimusops:mimusops属
words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#\$');
β
https://www.textmagic.com/free-tools/unicode-detector
https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}