use strict;
my $str = '
article 11367 airline experts incheon airport transfers operational expertise indonesia
article 8364 future investment korean government invest 4 trillion won science technology ict rd
article 2151 fighter procurement lockheed martin able propose lower prices f 35s
';
my $regex = qr/^\S+\s+\K\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";