using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#&\s])\1+";
string substitution = @"\1";
string input = @"Actividades Financieras && Bancarias #### 23";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}