$re = '/([#&\s])\1+/';
$str = 'Actividades Financieras && Bancarias #### 23';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;