use strict;
my $str = 'Actividades Financieras && Bancarias #### 23';
my $regex = qr/([#&\s])\1+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";