import re
regex = re.compile(r"([#&\s])\1+")
test_str = "Actividades Financieras && Bancarias #### 23"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)