const regex = /([#&\s])\1+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([#&\\s])\\1+', 'g')
const str = `Actividades Financieras && Bancarias #### 23`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);