#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#+.+\s+(?<paragraph>[^#]+)(?:\n\n|$)"
Local $sString = "## Column A (Heading)" & @CRLF & _
"Paragraph A (Content)" & @CRLF & _
"" & @CRLF & _
"## Column B (Heading)" & @CRLF & _
"" & @CRLF & _
"Paragraph B (Content)" & @CRLF & _
"Paragraph B (Content)" & @CRLF & _
"Paragraph B (Content)" & @CRLF & _
"Paragraph B (Content)" & @CRLF & _
"" & @CRLF & _
"## Column C (Heading)" & @CRLF & _
"Paragraph C (Content)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")